Slow Car Fast
LIFE OF A GT
December 1, 2010 - The roller is a pretty nice tool.
It allows you to slowly and carefully shape the fender, rolling that flat flange upwards so it gives more room without any visible changes. It's easier on an unpainted panel like this, of course, but I've made some fairly spectacular alterations to a couple of Miatas. In extreme cases, you can stretch the fender outwards for more space. I didn't have to do that here.
It might seem a little odd to build a custom fender and them immediately modify it like this, but it's part of getting the best fit.
So how's it look? Pictures will be forthcoming once I get the car out of the garage. Basically, the car's gone from looking pretty cool to just plain badass.
entry 498 - tags: fender roller, flares, fenders, body
December 2, 2010 - The final result!
I'll hit it with some black primer to protect the metal and make the shape blend into the body, but I'm really happy with the result.
entry 499 - tags: fenders, flares, body
December 2, 2010 - Another view from the front quarter.
Sorry about the exposure, the Colorado sun is pretty harsh for photography. I'll get some better ones later.
After some playing around yesterday, I decided that rear Rabbit flares (as seen on the rear of the MG) fit the front of the MG better than front Rabbit flares. Of course, I have a pair of junkyard front flares but no more rears. No worries, rabbitparts.com shipped me another set of patch panels yesterday and I should have them within a week. As a bonus, they're nice clean new metal like these instead of junkyard parts.
entry 500 - tags: body, fenders, flares
December 5, 2010 - I had time for some relatively quick and easy jobs this weekend, and I'm still waiting for the new set of flares to arrive.
So I started messing around with little trim pieces. First up was the tail lights. A few people had commented on how the older lights looked better. From pictures, I'd felt that was true for the convertible but not so much for the GT. But the 1969 parts car came with a set of the older ones, and I'd really come to appreciate the shape. So I swapped them over. Here, you can see one new old design light on the left and one old new design on the right.
entry 501 - tags: lights
December 5, 2010 - The rear end with the new lights.
Sharp eyes will also notice that I "shaved" the side markers as well (okay, I removed them and stuck a piece of black duct tape over the holes) and swapped the overriders for the older design. The 1972 ones have a rubber insert. Here's the "before" picture.
I'm really happy with the result. Janel described the older lights are more streamlined, and I think she's right on. They look much better. With all the changes, the car just looks cleaner from the rear. I actually had a set of new lenses for the previous taillights, but this is much nicer.
Of course, this light work wasn't without a certain amount of troubleshooting. The taillights weren't very well grounded, so I added a ground strap to make sure they worked consistently and well. A couple of dodgy bullet connectors also caused me to spend some time cleaning things up. I'll keep an eye on the behavior of those rear lights.
Sometimes it's nice to do the little things that make a satisfying difference. These sort of changes will make the whole car just work better, even if most people can't identify what was done.
entry 502 - tags: lights, wiring
December 5, 2010 - The messing about wasn't restricted to the rear.
In the front, I swapped the orange one-piece front lights for a set of older two-piece ones with clear lenses. This makes the whole front of the car monochrome with the exception of that MG badge, and again it cleans things up. The lights came with a set of white bulbs, but I installed a set of orange ones in the turn indicators to make them more visible when lit. The overriders were also changed out for the older ones. Again, it's a cleaner look than before.
The grille has been discussed before, a couple of years ago before I started on the engine conversion. It's a 1974 grille with a 1960's MG emblem, chosen because the black opening looks more aggressive than the old design to my eyes and because the newer emblem just looked cheap. Here's what the car looked like when we got it, with the overriders removed.
Less obvious is a set of new headlights. They're a set of European Bosch lights that put out a really nice pattern and let me run H4 bulbs. It's what a European MG would have, and the lighting is much better.
Again, not big changes. But ones that make me smile when I look at the car and will make it look better.
entry 503 - tags: lights
December 5, 2010 - Time to do some functional work.
I found what is likely a source of a fair bit of exhaust noise - the driver's side header outlet is leaning up against the footwell. Solidly enough to clear the paint off the footwell. So I pulled the header and exhaust pipe off and decided an effective fix would be a simple dent. A slot in the footwell, a few hammer blows and voila, lots of room. Given the shape of the footwell, it's unnoticeable from inside the car. I covered up the slots with seam sealer and I'll put it all together again shortly. I'm excited to see if this makes a big difference to the sound - I suspect it's where a fairly loud rumble/vibration at higher loads and highway cruise was coming from.
entry 504 - tags: exhaust
December 16, 2010 - I've been out of town for over a week, so the MG hasn't seen much action.
But the whole time I was gone, I was thinking about the fact that my new front fenders should be arriving. Less than 24 hours after getting home, I had the new fenders cut up and was doing test fitting.
And here's where I ran into a problem. Cars taper. They tend to be wider in the middle than the ends. Both the Rabbit and the MGB are like this. So the flares are slightly tapered to match. In the rear, I used the rear fenders on their intended sides and so the taper worked out well. But in the front, I had to flip the fender pieces - from a rear Rabbit fender - to the other side if I wanted the taper to work with me. Unfortunately, no matter how I played with them, I just couldn't get them to sit well on the original wheel cutout.
By flipping them back again - left fender on the left side - I was able to get the shape I wanted with a delicious little curl where the flare melts into the body of the car. That's a great detail on the original Rabbit that you can see with the bumpers pulled. But it meant that the flare was tapered the wrong way. The front of the wheel is left more exposed and there's a bit more flare on the trailing edge. Still, I thought it worked pretty well, so that's what I've done. We'll see what I think when it's all painted up and finished.
I did do a lot more trimming on the metal to deal with this and to mold the flares to the body. I usually find tin snips to be terribly frustrating devices but this turned out to be their destined use. A nice change from noisy power tools that are always trying to fling incandescent metal into my eyeballs.
entry 505 - tags: fenders, flares, body
December 16, 2010 - Just as in the rear, I had to add a filler piece to mate the flare to the body.
However, unlike the rear, it was trying to mate up to a fairly heavily curved fender. It looks a bit weird in the picture, but I think it'll look good when it's all painted.
I hope so anyhow.
entry 506 - tags: fenders, flares, body
December 17, 2010 - With both fenders welded up, I hit them with some black primer and brought the car out into the sun to see how it looked.
The answer: Pretty darn good. Obviously they're not finished yet, I only knocked down the high points on the welds so they wouldn't be too distracting.
The two front fenders came out slightly different, mostly in how the extra patch blends in. On the driver's side here, it's a straight line to the fender. On the passenger's side, there's a change in angle. I like the former, so I'll probably go back to the other side and add a bit more steel - I should be able make it work nicely.
The car looks pretty good now! Much less redneck.
entry 507 - tags: body, fenders, flares
December 17, 2010 - A view of the passenger's side.
You can't really see the difference in the front flares here. I think the car looks good - my concerns about the taper of the flares were a bit premature, as the final result blends in nicely. The rears still work a bit better in my opinion, but I'm pretty happy. There are so many ways this could have gone wrong.
Check out the strip down the side - it's just foil tape cut to width and stuck on to get a feel for how it will look. After the bodywork is finished and the car is painted, I'll cut down a set of stock stainless steel strips and make them fit.
entry 508 - tags: body, fenders, flares
December 17, 2010 - The best angle.
I want to spend a bit more time walking around the car and getting a feel for how it looks (and learning to photograph it well!), but I'm happy with this. It almost looks as if it should have come from the factory this way, which was my goal. I can see a few things I'd change if I did it again on the fronts (especially now that I've learned a few things about fitting the metal) but that's just my reaction after spending a few days working on them. It's like the stripes on the Targa Miata - I'm not happy with how they flow on one corner or around the rear taillights, but nobody else has ever noticed.
To celebrate, we used the car for a bit of running around town including some grocery shopping. Naturally, my freshly-adjusted latch on the tailgate decided to get ornery and refused to open, so we had to load all the groceries in through the front doors. The car's still fairly loud, but I think I managed to solve the major vibration problem. We'll see when I get it on the interstate. Still have to fix that bit of stiction in the steering though...
entry 509 - tags: fenders, flares, body
December 20, 2010 - It's been a busy few days.
On Friday night, Janel and I took the MG out to run an errand or two - which turned into a big grocery shopping trip as well as other events. Of course, I had just adjusted the rear hatch and it refused to open again. So we had to load all the groceries in through the back seat. A tip for those who are planning to use an MGB GT for a station wagon - anything you put in the back is on clear display! Unless you stash it in the smuggler's hole underneath where the spare tire lives. Anyhow, a bit of lubrication when we got home and the problem was solved.
We also got a little hiccup when the engine died a block from home. It fired right up again, but that was a bit odd. My suspicion was low fuel.
The next morning, I jumped in the car to go to the opening of a new car museum close by the house. While sitting at a stop sign, the engine died again and would not restart. Banging on the bottom of the tank gave a very empty BONG, so my chase car (a Miata with a 480 hp LS3, of course) took off to get some fuel. My theory was that the fuel gauge (the original, on the original sender and wiring) wasn't quite calibrated right - or, as a safety margin, it never went completely to E because then it would appear to be not working!
The fuel arrived. That didn't work. Bill Cardell (the driver of the Miata) and I figured out the fuel pump wasn't running. And then it was - there must be a slightly dodgy connection in the system somewhere. I got to the museum and back without incident, but it really highlighted that I'm not just debugging my own work over the last two years, but also a 38-year-old British car that never really functioned fully when I first got it.
I'd like to point out that it's not a Lucas fuel pump, but a good Pierburg unit. Just before the Lucas jokes start...
The photo? I just like the way the car looks!
entry 510 - tags: debugging
December 20, 2010 - I was asked for a side shot of the flares, showing how they fit over the wheels.
And here it is.
The Lucas bullet connector between the new wiring and the fuel pump has been replaced. The culprit? I don't know. I also discovered that I never tightened down some of the connections on the main power bus, so it's possible that could be a culprit.
entry 511 - tags: body, fender, flares
December 20, 2010 - Time to find out why the steering feels a bit odd.
It doesn't have much self-centering and almost feels as if there's too much friction in the system somewhere. Step one: lift the front wheels off the ground and get a feel for it. Step two: start removing various components to find the friction. It's 100% Miata steering, so it should work well.
The first thing I pulled off was the steering wheel and compared it to a stock Miata unit. Bingo. Nice and free movement. Wow, that was easy to find. Experimentation with a few other wheels (yes, there are five on the workbench) traced the problem to an adapter that had slightly oversize splines. This let it slide too far down on the column and put a lot of pressure on the turn signal canceling mechanism.
entry 512 - tags: steering
December 20, 2010 - The solution to the bad adapter was to replace it.
This unit - of unknown origin - would bottom out a full 1/2" higher up on the column, avoiding the problem. But it was both too short and had the wrong bolt pattern for the wheel. So I cut both apart and welded them together using a piece of pipe as the spacer. Nice and solid, and with some attention to detail everything is parallel and centered. There's a rubber boot that slips over this so you can't see it.
A quick test drive showed a massive change in the steering feel, with good centering and lighter effort. Time well spent.
entry 513 - tags: steering
December 20, 2010 - Okay, so now that I can steer, it's time to find out how fast I'm going.
The T56 transmission puts out an electronic signal. Naturally, the MG speedo uses a mechanical drive. There's a solution to this that involves a little motor in a box that spins a speedometer cable to match an electrical signal, but it's fairly expensive. For less money, I found a Smiths programmable electronic speedometer! I've been waiting for this part to show up for well over a month now, it seems they're made to order by British craftsman and, well, it takes time. But it'll fit into the MG's instrument cluster better than any other gauge, right down to the font on the numbers. The black center on the needle is the biggest giveaway really. I had my choice between 140 or 170 mph ranges, and I figured the 140 would be easier to read in the sane ranges - and above 140, I need to keep my eyes on the road!
When I went to hook it up, I found another advantage to using a Smiths part. They still use the same Lucas wire colors! Switched power is green, instrument lighting is red with a white stripe - makes it easy. But I did have a bit of trouble.
The GM engine computer (PCM) puts out a digital signal to run the factory speedometer. So that's easy, just plug it into the input on the speedo and away we go. Umm, no. With the rear end up on jackstands, I ran the car in gear and nothing happened. I tried the "low voltage" setting and nothing.
A bit of research on LS1Tech.com revealed that the PCM puts out a square wave signal that doesn't always play well with aftermarket speedos. The solution is to pull the signal right off the transmission. Okay, that's easy enough. I spliced into the transmission VSS signal and tried again.
This time, the speedometer woke up but it was acting odd. It would pin, or just hover mid-range but not consistently. Finally, I discovered that by letting the car idle in first gear I could get a 70 mph reading. According to the OBD-II reader, the PCM thought I was going 7 mph. So my calibration was off by an order of magnitude!
I quickly set up the speedo to count 40,000 pulses per mile and it settled right down. It's still not properly calibrated (what would be the odds?) but it's in the ballpark now. I just need to check some numbers, do the math and input the proper calibration. Getting closer...
entry 514 - tags: instruments, speedometer
December 20, 2010 - While the dash is out to work on the speedometer and other wiring, I've decided to remove the crappy tan paint on some of the parts.
Most of the interior of the car was painted pretty well, but the dash itself hasn't weathered well. It's cracked on top too. The eventual plan is to recover it with fresh vinyl (or a metal dash if I can hunt down all the parts), but in the meantime I want to work with what I have.
These dash vents are no longer available. But a few minutes in the bead blaster brought them back from ugly to original!
entry 515 - tags: interior
December 21, 2010 - A peek at the dashboard.
It used to be a very shabby looking thing, it's looking much better now! Not exactly concours-ready - my technique of dealing with a crack above the speedometer was to put some black duct tape over top before painting - but it's worlds better. You can see dusty hand prints above the tach, the paint job isn't as patchy as it looks in the picture.
Although looking at that old shot of the interior, I see I have the location of some of the lights in the wrong place - the right turn indicator and the alternator light seem to have traded spots. That'll be a bit of a pain to change now, as I took a special effort to make sure they're properly anchored!
entry 516 - tags: dash, interior
December 21, 2010 - Time to wire up the wipers.
This should be straightforward, right? Well, no. Things started off easily enough, with one wire for low speed and one for high speed. I'm not exactly sure how to duplicate the intermittent setting, but that's no big deal.
But the Lucas wipers have an extra wire that is for the parking function, to return the wipers to home base if you turn them off halfway through a stroke. It's a 12v signal that is fed back through the low-speed circuit until the wipers are parked. I've been inside a Lucas wiper motor and it's a reasonably intelligent way of doing things mechanically in my opinion, but the problem comes from the fact that there's some switching that needs to be done inside the wiper switch. My Miata wiper switch doesn't have this internal logic. So I need to find some way to have the park wire connected to the low speed wire when the wipers are off, and disconnected when they're on. That's easy enough to do with a relay...except for the fact that I have to have the high speed setting do the same thing.
Finally, after a bit of scratching around, I figured a way to do it with a relay and a couple of diodes, without passing the load from the wipers through the diodes. Out came the soldering iron and it all went together well. There's still one odd behavior, the wipers move fairly slowly in "park" mode even though they're seeing full voltage and theoretically full amps. I'm not sure what's happening there, as I'm pretty sure they worked well before the relay went in. I'll revisit it tomorrow to see what's going on.
I did manage to get the squirter working today, and discovered that it's aimed in completely the wrong direction much to my amusement. As a bonus, the Miata wiper switch includes some logic that swipes the wipers three times after you trigger the washer. Excellent.
Oh, and horns now work as well. Meep meep!
entry 517 - tags: wipers, electrics